Author Topic: 1969 Cadillac Washer Pump  (Read 887 times)

Offline ILM69Cadillac

  • Posts: 23
1969 Cadillac Washer Pump
« on: September 13, 2010, 12:13:58 PM »
My windshield washer pump seems to be malfunctioning, it clunks and runs whenever the wipers are on (misaligned cam?) unfortunately it is a cheap aftermarket pump and doesn't even have a way to align the cam I think it is a self guiding cam (a little different than OEM) and is broken. I have spent two hours trying to get it to align up correctly and think it's time to just replace it. Are there any good aftermarket or good OEM ones available? All I have been able to find is that "HELP!" Dorman pump and do not know if it is any good?
1969 Cadillac Fleetwood Series 75 Sedan, Black
Torin Kirkpatrick
Member# 21289

Re: 1969 Cadillac Washer Pump
« Reply #1 on: September 13, 2010, 04:15:49 PM »
That pump is still listed as available from AC Delco.
Greg
Cadillac Kid-Greg Surfas
Director Modified Chapter CLC
CLC #15364
66 Coupe deVille (now gone to the UK)
72 Eldo Cpe  (now cruising the sands in Quatar)
73 Coupe deVille
75 Coupe deElegance
76 Coupe deVille
79 Coupe de ville with "Paris" (pick up) option and 472 motor
514 inch motor now in '73-

Offline ILM69Cadillac

  • Posts: 23
Re: 1969 Cadillac Washer Pump
« Reply #2 on: October 15, 2010, 11:43:19 AM »
I have replaced the wiper motor with a rebuilt unit and have installed a new AC Delco washer pump!! Now the wipers keeps running for a while after the switch has been shut off before it wants to turn off!!! Not the usual 1 or 2 wipes once the switch is off but for a full minute!! Is this a problem with the rebuilt unit?
1969 Cadillac Fleetwood Series 75 Sedan, Black
Torin Kirkpatrick
Member# 21289

Offline Dave Shepherd

  • Posts: 2426
Re: 1969 Cadillac Washer Pump
« Reply #3 on: October 15, 2010, 12:50:00 PM »
That can be caused by the latching relay in the motor/pump assy. or a bad ground from the switch to the motor.

Offline ILM69Cadillac

  • Posts: 23
Re: 1969 Cadillac Washer Pump
« Reply #4 on: October 15, 2010, 01:44:43 PM »
Thanks!! I will double check the ground but I bet it is that rebuilt unit!
1969 Cadillac Fleetwood Series 75 Sedan, Black
Torin Kirkpatrick
Member# 21289

 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13