Author Topic: No Heat for my 68 Eldorado  (Read 1906 times)

Offline Forgiven1989

  • Posts: 85
  • Name: Dave Gipson
No Heat for my 68 Eldorado
« on: October 07, 2012, 04:11:27 PM »
I just found out that my 68 Eldorado is not putting out any heat.  Also the air blows only out of the AC vents when lever is in low, medium, or high.  The defrost works but without any heat.  This is when the dial is set all the way to 85 degrees.  The heater hose going into the heater core is hot. Does anyone have any ideas?  Thanks.

Offline TJ Hopland

  • Posts: 10188
Re: No Heat for my 68 Eldorado
« Reply #1 on: October 08, 2012, 09:16:38 AM »
So the air will move from the vents to the windshield if you move the control?   I was thinking you had a dead programmer or no vacuum but if part of it moves you have some vacuum and some functions working.   

There is a door in the duct work that controls how much of the air flow goes through the heater core.  There is then another set of doors that controls where the air comes out.   They are all vacuum operated. 

Hopefully someone with more experience on a 68 than me can tell you some specific places to start checking.
StPaul/Mpls, MN USA

73 Eldo convert w/FiTech EFI
80 Eldo Diesel
90 CDV
And other assorted stuff I keep buying for some reason

Re: No Heat for my 68 Eldorado
« Reply #2 on: October 08, 2012, 09:53:01 AM »
Dave,
Take a look at the "power servo" actuator under the hood.  It is the large Vacuum cylinder on top of the AC/Heater box with the control cable and vacuum control lines going to it.  There should be a large vacuum line going to the center of the "end" of the servo.  When you turn the temperature control dial all the way to 85 degrees, with the engine running (and warm), and the  selector lever on "auto" is there any vacuum at hat  hose connection (the large one, not the several small hoses connected to the power servo in a multiple hose connection0?
Greg Surfas
Cadillac Kid-Greg Surfas
Director Modified Chapter CLC
CLC #15364
66 Coupe deVille (now gone to the UK)
72 Eldo Cpe  (now cruising the sands in Quatar)
73 Coupe deVille
75 Coupe deElegance
76 Coupe deVille
79 Coupe de ville with "Paris" (pick up) option and 472 motor
514 inch motor now in '73-

Offline Forgiven1989

  • Posts: 85
  • Name: Dave Gipson
Re: No Heat for my 68 Eldorado
« Reply #3 on: October 08, 2012, 07:08:28 PM »
Greg,  There was no vacuum at the power servo.  So I hooked a vacuum hose directly from the engine.  Now there is maxium heat.  Do you think that it could be the transducer since that is where the vacuum source comes from?  Thanks.

Offline Dave Shepherd

  • Posts: 2425
Re: No Heat for my 68 Eldorado
« Reply #4 on: October 08, 2012, 07:37:03 PM »
One possibility, but the transducer is controlled by the programmer and control head, based on sensor inputs, some diagnostics are in order here, a oe manual will walk you thru the process.

Offline Forgiven1989

  • Posts: 85
  • Name: Dave Gipson
Re: No Heat for my 68 Eldorado
« Reply #5 on: October 08, 2012, 08:32:57 PM »
Thanks.

Offline cadillactim

  • Cadillac Tim
  • Posts: 799
Re: No Heat for my 68 Eldorado
« Reply #6 on: October 09, 2012, 09:49:06 PM »
Make sure you have engine vacuum at small port of transducer. If so, then make sure the vacuum line from the transducer to the power servo  is not clogged or leaking. If that vacuum line is okay, unplug the black and white wire going to transducer. System should go to full heat. If not, check to see if there is at least 10 inches of vacuum at the power servo. If not, transducer is bad. If there is at least 10 inches of vacuum, power servo is leaking.  Tim
Tim Groves

Offline Forgiven1989

  • Posts: 85
  • Name: Dave Gipson
Re: No Heat for my 68 Eldorado
« Reply #7 on: October 13, 2012, 10:11:51 PM »
Thanks.

Offline Jeff Maltby 4194

  • 49 fastback
  • Posts: 1987
  • Deceased Member.
Re: No Heat for my 68 Eldorado
« Reply #8 on: October 15, 2012, 10:32:47 AM »
Here's one off of a 67 Eldo.
Jeffo 49er chapter

CLC 1985
Honda Gold Wing GL1500

Offline Jeff Maltby 4194

  • 49 fastback
  • Posts: 1987
  • Deceased Member.
Re: No Heat for my 68 Eldorado
« Reply #9 on: October 25, 2012, 11:55:10 AM »
Here's the heater box.
Jeffo 49er chapter

CLC 1985
Honda Gold Wing GL1500

 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13