Is my 58 riding too high in the front end?

Started by Matt Innocenzi #21633, October 12, 2005, 10:29:19 AM

Previous topic - Next topic

Matt Innocenzi #21633

Hello all - I am getting ready to put the ol girl in the garage for winter storage and this will be a good opportunity for me to do all the maintenance, waxing and cleaning for her.  One thing I noticed over this year is the car seems to be riding high in the front end (or maybe low in the rear end).  I replaced all the shocks in 2003 and just last week, I replaced the bushings and end links in the front sway bar.  The old end links were in poor condition and when I put in the new bushings, the car came down a tad in the front, but still looks silly to me.  Were they originally made to ride a little high in the front?  I am going to attempt to attach a picture, but if it does not work, please let me know and I can e-mail some for your review.  

Assuming the car is riding too high in the front, what can be done to lower it?  Any help would be greatly appreciated!

<img src="http://www.minnocenzi.photosite.com/~photos/tn/36_348.ts1117421992000.jpg">

Mike #19861


 To my eyes it does. I find that quite often replacement springs are of the wrong length or tension and tend to raise the car much above standard ride height.

 To check correct height, there is a procedure and specifications outlined in the shop manual. If you do not have one, perhaps someone here that does could furnish the specs and procedure.

  Mike

Matt Innocenzi #21633

Hi Mike, Thanks for the reply.  To the best of my knowledge, the springs are the original, but maybe I should check with the last owner.  Short of replacing them, I assume there is nothing I can do?

I have the 1957 and 1958 Shop Manuals - Ill check them out too.  Thanks!