Author Topic: '93 Deville Alternator charge light  (Read 1311 times)

Rob Bruining #12428

  • Guest
'93 Deville Alternator charge light
« on: November 27, 2007, 09:39:28 PM »
My recently installed alternator quit charging. I only knew because the car would barely start one morning. The battery was down to 10 1/2 volts. The discharge light never came on. I know it's not burned out as when I turned the key to the ruin position it lit up. What's going on? I would like to know if it ever quits charging again. Thanks for any "light " you can shed on this problem.

Offline TJ Hopland

  • Posts: 10193
Re: '93 Deville Alternator charge light
« Reply #1 on: November 28, 2007, 09:29:04 AM »
I would say check and clean all the the connections to do with the battery and alternator.  Then try checking and cleaning the connections. Then you may want to check and clean connections. Look close at / for ground straps between the body and engine.  It also seems to be very common now days to get bad alternators (both new and rebuilt).  You could have a bad battery. A loose internal connection may conduct enough voltage to keep the light off but not when you need it.   You could try swapping a battery in from another car and see if there is any sign of the problem moving.   What is the system voltage when running?  You could rig up a volt meter hooked in the cigar lighter socket so you can check it from time to time while driving and starting.
« Last Edit: November 28, 2007, 09:30:56 AM by TJ H »
StPaul/Mpls, MN USA

73 Eldo convert w/FiTech EFI
80 Eldo Diesel
90 CDV
And other assorted stuff I keep buying for some reason

 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 


All Cads